Update Samsung Galaxy Spica/Lite/Portal i5700 to Android 2.2 sign now

We would like Samsung to update the Galaxy SPICA/Lite/Portal phone (also known as i5700) to Android 2.2 as we feel that the device is fully capable of supporting the features in the new OS and it is still too early to stop supporting the device. Of course, if you (Samsung) are intending to update the phone to 2.2, thank you so much! This is just to preempt any occasion where Samsung announces that it has no plans to update the device.

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in, otherwise register an account for free then sign the petition filling the fields below.
Email and the password will be your account data, you will be able to sign other petitions after logging in.

Privacy in the search engines? You can use a nickname:

Attention, the email address you supply must be valid in order to validate the signature, otherwise it will be deleted.

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Shoutbox

Who signed this petition saw these petitions too:

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in

Comment

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Goal
0 / 50000

Latest Signatures

No one has signed this petition yet

Information

Nelson PughBy:
Business and CompaniesIn:
Petition target:
Samsung

Tags

No tags

Share

Invite friends from your address book

Embed Codes

direct link

link for html

link for forum without title

link for forum with title

Widgets