Fix the lack of SM 2.0 support in current and future games sign now

We, as faithful and loyal customers of ATI, would like to urge the said company to develop a workaround in their Catalyst drivers so that all current Shader Model 2.0/2.0b Radeon cards can render the Shader Model 3.0 effects. Even something as simple as a wrapper(that fakes Shader Model 3.0 support by converting SM 3.0 instructions to SM 2.0 ones) will be acceptable rather than the current situation of having to contend with games that will resort to turning off enhanced graphics on ATI hardware. It is our wish that ATI should work more closely with game developers and ensure that the games include alternative 2.0/2.0b shaders for the thousands of existing ATI hardware owners.

Read the following thread to understand the issue in more detail:

http://techreport.com/forums/viewtopic.php?t=28412

Thank you.

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in, otherwise register an account for free then sign the petition filling the fields below.
Email and the password will be your account data, you will be able to sign other petitions after logging in.

Privacy in the search engines? You can use a nickname:

Attention, the email address you supply must be valid in order to validate the signature, otherwise it will be deleted.

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Shoutbox

Who signed this petition saw these petitions too:

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in

Comment

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Goal
50 / 100

Latest Signatures

  • 29 November 201550. Keith G
    I support this petition
  • 18 October 201549. Ps Atp
    Model of DX9 compatible Radeon Sapphire ATI Radeon 9550 256 GDDR Name of the game with no support for Shader Model 2.0/2.0b Medal of Honor Airborne,Spiderman 3,Bioshock,Latest from ea games and ubi and activision and thq Its not correct that games need o
  • 16 August 201548. Oliver T
    I support this petition
  • 28 March 201547. Troy J
    Model of DX9 compatible Radeon Saphire 9200 256 Name of the game with no support for Shader Model 2.0/2.0b Lots/Crysis to mention one. If it's possible, it should of never became an issue.
  • 28 December 201446. Arhan K
    I support this petition
  • 25 December 201445. Op Singleton
    I support this petition
  • 09 August 201444. Devin M
    Model of DX9 compatible Radeon x850xt Name of the game with no support for Shader Model 2.0/2.0b Bioshock bull.
  • 14 February 201443. Niklas Herman
    I support this petition
  • 08 February 201442. Paul Zamora
    I support this petition
  • 20 January 201441. Tim D
    I support this petition
  • 07 January 201440. Sajith Ellison
    I support this petition
  • 27 August 201339. David D
    I support this petition
  • 31 July 201338. Ryan A
    I support this petition
  • 24 March 201337. Adeel A
    I support this petition
  • 28 December 201236. Larry G
    Model of DX9 compatible Radeon Radeon x800 Pro Name of the game with no support for Shader Model 2.0/2.0b Spiderman 3 Can't return game out $30.00
  • 27 December 201235. Teodorescu R
    Model of DX9 compatible Radeon X800XT PE Name of the game with no support for Shader Model 2.0/2.0b gears of war please do something about this so that ati cards currently supporting sm 2.02.0b will have support for sm 3.0
  • 07 December 201234. Juan Carlosperaltah
    Model of DX9 compatible Radeon Ati x800xt AIW Name of the game with no support for Shader Model 2.0/2.0b Lost Planet. Bioshock. Rainbow sis Vegas. Colin mc rae dirt... I can't believe in 3 months, my graphic card can't run any of those games
  • 20 October 201233. Mito Delacruz
    I support this petition
  • 19 July 201232. Scott Faulkner
    I support this petition
  • 24 December 201131. John D
    I support this petition
  • 07 December 201130. Sameer A
    Model of DX9 compatible Radeon x800xt Name of the game with no support for Shader Model 2.0/2.0b future games sm 2.0 rocks !!!
  • 02 August 201129. Guilherme Mcneil
    I support this petition
  • 17 June 201128. Shabbir K
    I support this petition
  • 06 March 201127. Shadow Ortiz
    I support this petition
  • 28 February 201126. Issa Shea
    Model of DX9 compatible Radeon msi ati radion 9550 Name of the game with no support for Shader Model 2.0/2.0b need for speed carbon need sm 3.0
  • 11 March 201025. Sawek Larson
    Model of DX9 compatible Radeon DX9.0 Name of the game with no support for Shader Model 2.0/2.0b 2.0 -
  • 01 February 201024. Ali K
    Model of DX9 compatible Radeon Radeon X800 XT Name of the game with no support for Shader Model 2.0/2.0b Splinter Cell It sucks that I shall have to settle with 1.1 pixel shader on my expensive card

browse all the signatures

Information

Staci HahnBy:
Transport and infrastructureIn:
Petition target:
http://www.ati.com

Tags

No tags

Share

Invite friends from your address book

Embed Codes

direct link

link for html

link for forum without title

link for forum with title

Widgets