Firmware 2.71 & Below - PSP UMD Discs sign now

What this petition is trying to come forth with is to make all of the 2.80 (and up) firmware requires PSP games, not require 2.80 (and up)... but instead, 2.71. The reason we are doing this is because we are sick of updating and updating to play each game that we buy/rent/borrow. Eventually, our PSP will brick as a result of too many upgrades. If it bricks, we will not want to send it to Sony and have to wait 3 months or more to get another one back and buying another one is a waste of money and no one will want to buy a 'useless' PSP.

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in, otherwise register an account for free then sign the petition filling the fields below.
Email and the password will be your account data, you will be able to sign other petitions after logging in.

Privacy in the search engines? You can use a nickname:

Attention, the email address you supply must be valid in order to validate the signature, otherwise it will be deleted.

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Shoutbox

Who signed this petition saw these petitions too:

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in

Comment

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Goal
0 / 50

Latest Signatures

No one has signed this petition yet

Information

Greta NewtonBy:
LGTBIn:
Petition target:
Sony Computer Intertainment; PSP

Tags

No tags

Share

Invite friends from your address book

Embed Codes

direct link

link for html

link for forum without title

link for forum with title

Widgets