BlackBerry Desktop Manager for Windows 3.1 sign now

We the people of legacy computer machinery demand the compatibility and support of BlackBerry Desktop Manager working for Windows 3.1 via the 5inch floppy installation. It's so ridiculous that I have to have a super computer and a state of the art 2x CD ROM to install Desktop Manager.

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in, otherwise register an account for free then sign the petition filling the fields below.
Email and the password will be your account data, you will be able to sign other petitions after logging in.

Privacy in the search engines? You can use a nickname:

Attention, the email address you supply must be valid in order to validate the signature, otherwise it will be deleted.

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Shoutbox

Who signed this petition saw these petitions too:

Sign The Petition

Sign with Facebook
OR

If you already have an account please sign in

Comment

I confirm registration and I agree to Usage and Limitations of Services

I confirm that I have read the Privacy Policy

I agree to the Personal Data Processing

Goal
0 / 50

Latest Signatures

No one has signed this petition yet

Information

Connie FullerBy:
TelecommunicationsIn:
Petition target:
BlackBurry

Tags

No tags

Share

Invite friends from your address book

Embed Codes

direct link

link for html

link for forum without title

link for forum with title

Widgets